Admin RNA-seq 05

From Pitagora-Galaxy Wiki
Jump to: navigation, search

Main Page >> Admin >>

インストール手順

これら3つのツールを使用する

インストールするレポジトリは2つ

既にツールのリストに記載: ここ

trinityrnaseq

  • biomonica さんの trinityrnaseq: ここ
    • bowtie(bowtie2 ではない)が必要だが、dependency に定義されていない。

そこで

  • anmoljh さんの trinityrnaseq: ここ
    • trinity のバージョンが新しい? (r20140717)
    • bowtie と samtools も dependency に含まれている
    • しかし、こいつはこいつで package_trinityrnaseq_r20140717 のインストールでエラー
'latin-1' codec can't encode character u'\u2018' in position 30: ordinal not in range(256)


rsem

  • jjohnson さんの rsem
    • rsem ではこのツールが最新の模様。
    • package_rsem_1_1_17 のインストールでエラー。NCURSES が必要。
    • 先の trinityrnaseq で使われていた、anmoljh さんの package_ncurses_5_9 を含めればよいか。
bam_tview.c:5:20: error: curses.h: No such file or directory
bam_tview.c:7:2: warning: #warning "_CURSES_LIB=1 but NCURSES_VERSION not defined; tview is NOT compiled"
bam_tview.c:434:2: warning: #warning "No curses library is available; tview is disabled."
make[1]: *** [bam_tview.o] Error 1
make: *** [build-sam] Error 2

テストデータ